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Introduction:

Welcome to editing with Adobe Premiere Pro CC. Whatever your background with Premiere, we
hope to make your editing experience easier and more enjoyable with Adobe Premiere Pro. You
will be asked to take a short assessment at the end of the course.

The first step is to open the editing program. The icon for
Adobe Premiere Pro CC is located at the bottom of the
screen in the dock. To open the program click on the icon
one time.

The program will welcome you with a screen giving you
options either to open a current project or begin a new
project. Click “New Project”.

Next, Premiere will ask you what the file is to be named
and where it is to be saved. We encourage users to make
a new folder for each project.

Finally, your start screen will appear. This screen gives
quick access to most of premiere’s frequently used
functions. Please keep in mind that all of Premiere works
through “Panels”. Panels are useful because they can be
drug to different places depending on the user’s personal
preferences. To reposition panels, click on the name of the
panel and drag it next to a different panel title. The bar next
to the name will turn blue symbolizing that you can place
this panel here. In addition, Premiere also has
pre-positioned presets that align panels for you. These presets can be found in the form of tabs
at the top middle section of Premiere. You will see them in the order of “Assembly”, “Editing”,
“Color”, “Effects”, “Audio”, “Libraries”, “Graphics”. See examples below.
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A very important step that is often overlooked is to set the
sequence settings to match the video files that you have
shot. If you are to this stage of advanced editing then you
likely have a good understanding of camera resolution. Most
things that you will be shooting will be 1080p full HD.
Navigate to File > New > New Sequence. A dialogue box
will appear asking you to name your new sequence and
define the resolution. From here you can choose the
resolution and frame rate appropriate.

One final step that needs to be taken before we start
editing is to set the “Scratch Disks” or “Media
Cache”. To do this, navigate to Edit > Preferences
> Media Cache. A dialogue box will open. Click on
the “Browse” button and choose a folder. Once
again, we recommend a new folder be made for this
process. This helps to streamline your process and
minimize frustration if something falters.

Importing Assets:

Now that you have created a project, saved it
and set the media cache, you are ready to start
importing assets into your project. Assets are most
usually video clips, but can also consist of audio
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clips, photos or graphics. The easiest way to import assets is to open them in the Finder (Mac)
or File Explorer (Windows) and drag them directly into your project’'s media panel. This workflow
is handy because it can import folders as well as other
assets and place them in the panel in an organized
fashion. You can see how in my case | drug the entire
“New Folder” into the “Project” panel, and it imported the
entirety of it into Premiere. After you have drug your assets
into the panel they will import and you will have access to
them to begin editing.
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Editing:

Now you are ready to begin editing your clips and inserting them into your timeline. To
begin, double click on the clip that you want. This will open the clip up in the “Preview” panel.
Play through the clip once or twice using the spacebar to begin playback. The blue triangle, the
“‘Playhead”, indicates the current view point in the clip. From here you can select the in and out
points of your clip. The shortcuts for this function are the “I” key for the in point of your clip and
“O” key for the out point of your clip. When you have set the in and out points for your clip, click
on the center of the video and drag it to the timeline. It will appear in the form of a video bar and
two audio bars beneath. If your clip does not have audio then no audio bars will appear.
Premiere will automatically make a “Sequence” that
matches the settings of your video.

One feature to note is that there are two icons
directly underneath the video in your preview panel. One
resembles a film strip and the other resembles an audio
waveform. Clicking and dragging on the film strip will only
import the visuals of the video with no audio, whereas
clicking and dragging on the waveform icon will
exclusively import the audio from the clip into your
timeline. This can be useful when you know that you have
audio from another source and don’t want to bother with
the on-board camera audio that comes with your video
file.

You can continue to add
clips by repeating these steps.
Once you have all the clips that
you want placed into the
timeline you can now
rearrange, trim, resize and




recolor your footage to your heart’s content. Keep in mind that Premiere allows you to change
sequence settings at any time. | also want you to be aware that you can change your sequence
settings after you have imported and began editing.
To illustrate this, | have changed to the sequence to
resemble more of a film look by making the video
narrower. Instead of my video being 1920 x 1080 it is
now 1920 x 850. This is a common technique that is
meant to mimic the look of anamorphic type lenses
that actually output video in this aspect ratio. To
change sequence settings navigate to Sequence >
Sequence Settings. A dialogue box will appear and
give you the options for your sequence. Of course,
this is not a required step, but it is a good skill to know
if you ever run into problems.

Trimming and Cutting Clips:

Trimming a clip is very intuitive in Premiere Pro. Simply hover your cursor over the end
of one of your clips and handles will appear. Click and drag either way to either extend or
shorten your clip. Cutting clips is also made easy in Premiere. Navigate to the
“Razor” tool on the toolbar located in between your timeline and Project Media.
Select the Razor tool and hover above the clip on the timeline you want to cut.
Click on the clip and it will cut the clip in two right where you have clicked. The
shortcut for the Razor tool is the “C” key on your keyboard. This shortcut can
save a lot of time when editing and | would encourage you to become
accustomed with it among the other shortcuts.

Effect Controls:

One advantage that Premiere has over Adobe Elements is the extensive
amount of control you get over your clips. To access these controls, double click
on your clip in the timeline. You'll notice that the “Effects Control” panel will open where the
preview window was. If it does not open then go to the “Preview” panel at the top left and
select the Effect Control panel. This panel allows you to resize, change transparency and adjust
audio levels. You'll notice that all of the numbers that correspond with their respected setting are
blue. You can tell that they can be adjusted by their color being blue. To adjust scale, for
example, hover your cursor over the blue number to the right of Scale. Your cursor should turn
into a pointer with arrows, and from here if you click and drag you can adjust the parameter.
Pulling right will increase and pulling left will decrease. Nearly every parameter in Premiere can




be adjusted this way. Holding down the Shift key while you click and drag makes the changes
much more drastic.

Keyframes:

Another powerful function that is
included in the Effects Control panel is the
ability to add “Keyframes”. Keyframes are
tools that can be used for animating certain
parameters to change over time. For
example, let’s say that | wanted my video to
fade in. To accomplish this through
Keyframes | could put the playhead at the
beginning of the clip and add an opacity
keyframe set to zero. This can be done by
clicking the stopwatch icon to the left of the
word Opacity and bringing opacity down to
zero. You'll notice that this puts down a diamond icon. This is the icon that you can click to add
another keyframe any time that you wish. So if we scrub a few seconds onward and turn the
opacity up to one hundred it will automatically lay down another keyframe since we have
changed the opacity value. If we play back we can see that what it is essentially doing is
animating the opacity according to the keyframes we have made. We started with a keyframe at
zero and then moved a few seconds down and put down another keyframe that was at one
hundred. This brings the opacity value from zero to one hundred over the course of a few
seconds.
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Of course, keyframing opacity is not usually necessary as Premiere has many ways to
achieve a fade in transition that are quicker and easier. These can be incredibly useful,
however, for objects or settings that need to be animated. Color corrections can be animated as
well as text and other adjustments. Once you dig into all of the different ways that you can
keyframe and animate them, you will begin to see how the possibilities really are endless.

Titles and Text:

Adding titles and text to your video is easy with Premiere. Simply select the “T” button
on the tool select or click the “T” key on your keyboard as a shortcut. Next, click on the project
preview panel where your video is playing. There will then appear a red box and a blinking
cursor. Type whatever you would like your title to be. In addition, the Effect Control panel will
automatically divert to the text mode where you can adjust all aspects of your text like font, size,
color, etc.
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From the Effect Control panel you can see all of the settings that can be adjusted. Again,
you can see that many of the adjustments can be keyframed. If | wanted to make the title rotate
in | could so using Keyframes. Similarly, if | decided to animate it in by position | could also
achieve this through the use of Keyframes.

Premiere also gives you the ability to change the Fill, Stroke and Shadow of the text that
you have created. If you select the shadow it will drop down settings that can be adjusted. Here
you can change the angle, opacity, distance and blur of the shadow to fine tune the look that
you desire of your Drop Shadow.

Transitions:

Premiere has a huge selection of “Transitions” to choose from. You can find them by
clicking on the Effects Panel > Video
Transitions and then selecting the
category of transition you’d like. From
there you can pick the transition
desired. When you find the transition
that you want to use, click and drag it to
the cut where the two clips meet. This
will put a transition representation over
the two clips (see picture on next page).
To adjust the length of the transition
click and drag on either edge of the
transition.
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The temptation can be, of course, to go overboard with transitions. However, keep in
mind that fancy transitions do not necessarily make for a good video. Many movies, TV shows
and commercials often opt for a simple hard cut or fade transition rather than flashy transitions
between clips.

One time saving tip is that if you desire a crossfade between two clips that are laying
against one another to hover your cursor over the point where they intersect and right click. This
will bring up a box that has an option for “Apply Default Transitions”. If you select this option,
it will apply an adjustable fade in between these two clips.

Saving and Sharing:
Again, it is important that
you remember to save your
project often. Premiere does
auto-save, but not frequently
enough to be relied upon as a
permanent solution. We would MESSUEKETS
advise you to get used to saving
as often as you think about it.
The shortcut for it is Command
+ S (Mac) or Control + S
(Windows). Be sure to save
your project before exporting.

When you have
completed your project you need to submit it for playback on Fayetteville Public Access
Television. To export, go to File > Export > Media. A dialogue box will pop up. There are many



different settings and codecs that can be adjusted. There is not necessarily a right or wrong
codec to export to. We recommend the H.264 codec as it offers a very good and relatively
lossless image in a smaller file size. To choose this, click on the dropdown menu that is next to
the “Format:” setting. Drop the menu down and select the H.264 codec. Next, click on the blue
title of your project. This will open up the File Explorer or Finder and let you choose the
destination for your completed video. You are free to export in any way you wish. We do,
however, ask that you export a copy of your project for the purpose of being broadcast. Finally,
click the “Export” button to render your completed video.
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